emerchantpay - Temporary service disruption in 2nd step of 3DSv2 authentication with MasterCard and VISA
Incident Report for emerchantpay
Resolved
Dear Valued Partner,
Please accept our apologies for the inconvenience caused.
We have reviewed the issue with our MPI provider and can confirm that it is no longer present.
The affected are 3DS transactions, both Visa and Mastercard. It's related to MPI provider issues which have been resolved.
The issue was present from 19:45 to 21:35 UTC on Mar 20 2023.
In case you need further information or have noticed any issues, please feel free to reach us at tech-support@emerchantpay.com
Kind Regards,
Technical Support Team
Posted Mar 20, 2023 - 21:35 UTC
Update
We are continuing to investigate this issue.
Posted Mar 20, 2023 - 21:00 UTC
Investigating
Dear Valued Partner,

We have identified a partial disruption affecting 3DSv2 transactions authentication with MasterCard and VISA.

We are in close communication with the 3DS provider to resolve the problem as soon as possible and keep monitoring the transactions.
Please accept our apologies for the caused inconvenience.

Kind regards,
Technical Support Team
Posted Mar 20, 2023 - 20:32 UTC
This incident affected: emerchantpay.com and PRODUCTION (Genesis - web payment form (PRODUCTION), Genesis - API (PRODUCTION)).